专注收集记录技术开发学习笔记、技术难点、解决方案
网站信息搜索 >> 请输入关键词:
您当前的位置: 首页 > 人工智能

HDUJ 1151 Air Raid 最大婚配

发布时间:2011-07-03 07:42:34 文章来源:www.iduyao.cn 采编人员:星星草
HDUJ 1151 Air Raid 最大匹配

Air Raid

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3035    Accepted Submission(s): 1972


Problem Description
Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town's streets you can never reach the same intersection i.e. the town's streets form no cycles.

With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper.
 

Input
Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format:

no_of_intersections
no_of_streets
S1 E1
S2 E2
......
Sno_of_streets Eno_of_streets

The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town's streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections.

There are no blank lines between consecutive sets of data. Input data are correct.
 

Output
The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town.
 

Sample Input
2 4 3 3 4 1 3 2 3 3 3 1 3 1 2 2 3
 

Sample Output
2 1


#include<iostream>
#include<cstring>
using namespace std;

int n,m;
int a[150],v[150];
int b[150][150];

int f2(int x)
{
    for(int i=1;i<=n;i++)
    {
        if(b[x][i]&&!v[i])
        {
            v[i]=1;
            if(a[i]==0||f2(a[i]))
            {
                a[i]=x;
                return 1;
            }
        }
    }
    return 0;
}

int f1()
{
    int ans=0;
    for(int i=1;i<=n;i++)
    {
        memset(v,0,sizeof(v));
        if(f2(i))   ans++;
    }
    return ans;
}

int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        cin>>n>>m;
        int x,y;
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(int i=1;i<=m;i++)
        {
            cin>>x>>y;
              b[x][y]=1;
        }
        cout<<n-f1()<<endl;
    }
    return 0;
}


友情提示:
信息收集于互联网,如果您发现错误或造成侵权,请及时通知本站更正或删除,具体联系方式见页面底部联系我们,谢谢。

其他相似内容:

热门推荐: