专注收集记录技术开发学习笔记、技术难点、解决方案
网站信息搜索 >> 请输入关键词:
您当前的位置: 首页 > 编程

ZOJ3626-Treasure Hunt I

发布时间:2011-06-30 11:29:09 文章来源:www.iduyao.cn 采编人员:星星草
ZOJ3626---Treasure Hunt I
Treasure Hunt I

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Akiba is a dangerous country since a bloodsucker living there. Sometimes the bloodsucker will appear and kill everyone who isn't at his hometown. One day, a brave person named CC finds a treasure map, and he wants to get as much as possible.

Akiba consists of n towns and n-1 roads. There is a way from each town to any other. Each town contains some treasure values Vi. CC starts from town k(his hometown), at day 0. After m days, the bloodsucker will appear and CC would be killed if he hasn't been back yet, it means CC has m days for hunting the treasure at most. It takes CC Ti days to move from one town to another neighbour town.(Two towns called neighbour if they are the endpoint of one road.) You can assume CC will get the treasure immediately as he arrives at that town. CC wants to obtain as much value as possible, keeping him alive at the same time.

Input

There are multiple cases, about 50 cases.
The first line of each case contains an integer n, indicating there are n towns.
The following line describe the treasure's value in each town. "V1 V2 ... Vn". Vi is the value of the treasure in ith town. Each value is separated by one blank.
The next n-1 lines describe the n-1 roads in Akiba. "i j Ti" Means the ith town and the jth town are endpoints of that road. It takes Ti days to get through this road.
The last line has two integer k and m as described above.

1<=n<=100, 0<=Vi<=1000 , 1<=Ti<=10
1<=k<=n, 1<=m<=200
All the inputs are integers.

Output

Just output the max value CC can get, and you should keep CC alive after m days.

Sample Input

2
1 3
1 2 1
1 2
2
1 3
2 1 1
2 1
2
3 3
1 2 1
2 5

Sample Output

4
3
6

Hint

Sample 1: CC can go to town 2 and return at day 2.
Sample 2: CC can't come back within 1 day. So he can only take the treasure in his hometown.
Sample 3: CC only need 2 days to collect all the treasure.


树形dp, 设dp[u][i]表示用i天时间去访问以u为根的子树并且最后回到u,能够得到的最多的宝藏
dp[u][i] = max(dp[v][ j - cost[u, v] ] + dp[u][i - j] + val[v]);

/*************************************************************************
    > File Name: zoj3626.cpp
    > Author: ALex
    > Mail: 405045132@qq.com 
    > Created Time: 2015年01月02日 星期五 14时34分00秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

int dp[110][220];
int val[110], head[110];
int n, tot, m, k;

struct node
{
	int weight;
	int next;
	int to;
}edge[220];

void addedge(int from, int to, int weight)
{
	edge[tot].weight = weight;
	edge[tot].to = to;
	edge[tot].next = head[from];
	head[from] = tot++;
}

void dfs(int u, int fa)
{
	for (int i = head[u]; ~i; i = edge[i].next)
	{
		int v = edge[i].to;
		if (v == fa)
		{
			continue;
		}
		dfs(v, u);
		for (int j = m; j >= 0; --j)
		{
			for (int k = 2 * edge[i].weight; k <= j; ++k)
			{
				dp[u][j] = max(dp[u][j], dp[v][k - 2 * edge[i].weight] + dp[u][j - k] + val[v]);
			}
		}
	}
}

int main()
{
	int u, v, w;
	while (~scanf("%d", &n))
	{
		tot = 0;
		memset (head, -1, sizeof(head));
		memset (dp, 0, sizeof(dp));
		for (int i = 1; i <= n; ++i)
		{
			scanf("%d", &val[i]);
		}
		for (int i = 1; i <= n - 1; ++i)
		{
			scanf("%d%d%d", &u, &v, &w);
			addedge(u, v, w);
			addedge(v, u, w);
		}
		scanf("%d%d", &k, &m);
		dfs(k, -1);
		printf("%dn", dp[k][m] + val[k]);
	}
	return 0;
}



友情提示:
信息收集于互联网,如果您发现错误或造成侵权,请及时通知本站更正或删除,具体联系方式见页面底部联系我们,谢谢。

其他相似内容:

热门推荐: